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BACKGROUND 15 

 16 

Meristems are groups of pluripotent stem cells typically located at the tips of shoots. Many 17 

fundamental features of meristems are shared across all vascular plants, e.g. the maintenance of a 18 

pool of undifferentiated cells, regulated cell proliferation and expansion, and control of post-19 

embryonic organogenesis. However, there remains a great deal of unexplored variation in 20 

meristem structure and behavior across land plants. Exploring this diversity is hampered by the 21 

reliance on common developmental techniques, such a fixed tissue sectioning and imaging that 22 

do not allow processes such as spatial and temporal patterns of cell division and expansion to be 23 

directly observed. In model systems such as Arabidopsis thaliana, genetic and molecular tools 24 

have been coupled with advancements in live imaging techniques that allow analyses of both cell 25 

behaviors and gene expression in real time, and these tools have provided considerable progress 26 

in our understanding of meristem development.  However, these advancements are currently 27 

limited to a small number of model species and there is a pressing need to develop quantitative 28 
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live imaging techniques in non-model systems, and specifically, approaches that may be broadly 29 

practical across a range of plant taxa. Here we present a detailed protocol for live imaging and 30 

analysis of floral meristems in Aquilegia coerulea, a member of the buttercup family 31 

(Ranunculaceae). This protocol provides a powerful tool to study the development of the 32 

meristem and initiation of floral organs and should be easily adaptable to many plant lineages, 33 

including other emerging model systems. This protocol will allow researchers to explore 34 

questions outside the scope of our common model systems.  35 

 36 

MATERIALS AND REAGENTS 37 

 38 

1. Petri dishes (35 x 10 mm; Corning, NY, USA) 39 

2. Agar (Invitrogen, catalog number: 16500-100) 40 

3. Linsmaier & Skoog medium (Caisson Labs, catalog number: L2P03) 41 

4. Sucrose (Macron Fine Chemicals, catalog number: 57-50-1) 42 

5. NaOH (Sigma-Aldrich, catalog number: 221465) 43 

6. Kinetin (Sigma, catalog number: K0753-1G) 44 

7. Gibberillic Acid (Sigma, catalog number: G7645-1G) 45 

8. Eppendorf tubes 46 

9. Parafilm 47 

10. 100% EtOH 48 

11. Aluminum foil 49 

12. Microscope slides 50 

13. Razor blades 51 

14. Propidium Iodide (Sigma-Aldrich, catalog number: P4864) 52 

 53 

EQUIPMENT 54 

 55 

1. Scalpel with No. 10 blade (BioQuip Products, #2723A) 56 

2. Straight dissecting needle (Carolina, #627201) 57 

3. Precision Watchmaker's Forceps, Extra-Fine Point (Carolina, #624791) 58 

4. Glass beads (Sigma-Aldrich, # 18406) 59 
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5. Microscope (Zeiss Stemi DV4 Stereo) 60 

6. Microscope (LSM 980 NLO Multi-photon with a water immersion lens W Plan-61 

Apochromat 20x/1.0 DIC UV-IR M27 75mm) 62 

 63 

SOFTWARE 64 

 65 

1. MorphographX (MGX) https://morphographx.org/software/. 66 

 67 

RECIPES 68 

 69 

Culture medium 70 

1. To make up 1L of the culture medium, dissolve 2.375 g of Linsmaier & Skoog medium 71 

(Fisher Scientific; final strength: 0.5X) and 30 g of sucrose (final concentration: 3%) in 72 

1L of ddH2O. The Linsmaier & Skoog medium should provide buffering capacity such 73 

that the pH of the solution should be about 5.8. If the pH is too high, adjust it with 1N 74 

NaOH solution. Then add 8 g of agar (final concentration: 0.8%) and autoclave.  75 

2. Once the autoclaved medium has cooled to a degree that is not too hot to be touched by a 76 

bare hand, add in 10-6 M kinetin (Sigma) and 10-7 M gibberellic acid (GA3, Sigma). Mix 77 

well and pour the plates in a fume hood to avoid contamination. 10-6 M kinetin and 10-7 78 

M GA3 can be diluted as follows: 79 

a. 10-6 M kinetin 80 

o Make 10-1 M stock solution: dissolve 21.52 mg kinetin in 1ml of 1N NaOH in an 81 

Eppendorf tube. Seal the tube tightly with parafilm. This stock solution can be 82 

stored at 4°C for a few months.  83 

o Add 1 µl of the stock solution in 100 µl ddH2O to reach the concentration of 10-3 84 

M 85 

o Add 1 µl of 10-3 M solution in every 1 ml of culture medium to reach the 86 

concentration of 10-6 M 87 

b. 10-7 M GA3:  88 
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o Make 10-1 M stock solution: dissolve 34.64 mg GA3 in 1ml EtOH in a 1.6 ml 89 

Eppendorf tube. Seal the tube tightly with parafilm. This stock solution can be 90 

stored at 4°C for a few months. 91 

o Add 1 µl of the stock solution in 1 ml ddH2O to reach the concentration of 10-4 M 92 

o Add 1 µl of 10-4 M solution in every 1 ml of culture medium to reach the 93 

concentration of 10-7 M 94 

 95 

PROCEDURE 96 

 97 

A. Plant materials and growth conditions 98 

 99 

1. Seeds of Aquilegia x coerulea ‘Kiragami’ can be purchased from Swallowtail Garden 100 

Seeds (Santa Rosa, CA, USA) and germinated in wet soil in plug trays, which generally 101 

takes two to three weeks.  102 

2. When the seedlings develop their first two true leaves, they are transplanted from plug 103 

trays to five-inch pots. Seedlings and young plants are grown in growth chambers with 16 104 

h daylight at 18 °C, 8 h dark at 13 °C, and humidity under 40%. In these regular growth 105 

conditions, the plants are watered twice per week. 106 

3. Once the plants develop five to six true leaves, they are transferred into the vernalization 107 

chamber which is set at 16 h daylight at 6 °C and 8 h dark at 6 °C. They should be well 108 

watered (i.e., the soil is fully hydrated) before being moved into cold conditions and are 109 

generally not watered during the vernalization period.  110 

4. Plants stay in vernalization for three to four weeks and then are moved back into regular 111 

growth chambers for flowering. We usually put a small amount of controlled-release 112 

fertilizer in each pot post vernalization. Inflorescences generally start to develop three 113 

weeks after vernalization.  114 

5. Dead leaves should be actively removed to pretend fungal or pest infections. 115 

 116 

B. Preparation of culture/imaging plates 117 

 118 
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1. Take an empty 1000µL pipette rack and gently press each foil square into one of the 119 

holes to create a round well. Cut small squares of aluminum foil (1x1cm). Carefully store 120 

foil squares in an autoclavable container (such as a glass petri dish) and autoclave.  121 

2. Autoclave glass beads and ddH2O. 122 

3. Prepare the media according to Recipe 1. 123 

4. While still molten, fill petri dishes half way with agar, quickly place one foil square in the 124 

center of the petri dish, concave side up. With sterile tweezers place a glass bead into the 125 

depression in the foil square (Fig. 1). This is sufficient to ensure that the convex side of 126 

the foil is pressing into the agar. Once the bead is put on the foil square, the foil will 127 

automatically gravitate to the center of the plate. Let the plates cool and solidify inside of 128 

the sterile hood. Once solid, using tweezers, remove the glass beads and carefully peel off 129 

the foil square. This leaves a shallow well in the agar for mounting the meristems. 130 

5. Solidified plates can be stored at 4°C for 2 months. 131 
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Figure 1. Making plates for live imaging. (a) Take an empty 1000µL pipette rack and gently 

press each foil square into one of the holes to create a round well. (b) A strip of wells. (c) Foil 

squares are autoclaved and stored in a glass petri dish. (d) Examples of plates solidifying in a 

sterile hood with foil squares and glass beads in place. (e) A plate with blue dye to show the 

well in the center, where the meristems will be positioned. (f) The plate then will be glued onto 

a microscope slide. The slide was labelled with dates, and A1-A4 were the meristem label and 

their relative locations in the well. 

 132 

C. Tissue dissection and mounting 133 

 134 
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1. The forceps, surgical needles, and dissection blades are all sterilized in 10% bleach, 135 

washed in ddH2O, and dried with Kimwipes before dissection.  136 

2. Young axillary inflorescences or whole inflorescences are excised off the plant using 137 

forceps or scissors for meristem dissections (Fig. 2).  138 

3. Inflorescences are washed in freshly prepared 10% bleach for 20 min. Any leaves and 139 

bracts on the stem should be removed using the forceps, but the attachment points of the 140 

petioles should be left on the stem (Fig. 2); if the petiole is completely removed from the 141 

stem, we found that the bleach solution will enter the wound and spread through the cells 142 

quickly, which kills the axillary meristems as well.  143 

4. The stems are then washed with double-distilled water (ddH2O) three times to completely 144 

remove the bleach residue, after which stems are kept immersed in ddH2O.  145 

5. When dissecting, put one stem under the microscope (the rest remaining in distilled 146 

water), and carefully remove the bracts and sepals of each floral meristem using the tip of 147 

a dissecting needle. Then excise the meristem off the branch with the scalpel, and transfer 148 

it onto a 35 x 10 mm petri dish (Corning, NY, USA) with the culture medium. Make sure 149 

the base of the stem (usually there is about 1 mm of stem remaining) holding the 150 

meristem is pushed into the agar. We typically mount four floral meristems per dish. 151 

6. Glue the petri dish to a microscope slide and label the date and the meristems on the slide 152 

(Fig. 1c). 153 

 
Figure 2. Developmental stages for dissecting FMs for imaging. Axillary meristems can be 

obtained from either a lateral inflorescence branch (a, b) or a young inflorescence (c, d). Scale 
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bars = 1 cm. Leaves that should be remove before or after the 10% bleach wash are indicated. 

Red dash lines indicate the locations where the floral axis will be excised for the bleach wash. 

 154 

D. Staining 155 

 156 

1. Meristems should be stained for 1-3 minutes in the petri dish by applying 50µL 157 

propidium iodide (0.5mg/mL) directly to the meristems. The mounting well should 158 

sufficiently contain the stain so that it creates a dome over the meristems. Take care that 159 

there is sufficient stain so that the meristems are fully immersed in stain throughout the 160 

whole staining period. It is important to note that the staining time will likely be specific 161 

to the plant and tissue being imaged, so here we just give a general time range and it is 162 

recommended that the staining time be optimized for each experiment. We would 163 

recommend starting with a low concentration for 1 minute and add time only if the tissue 164 

seems under-stained. Another important optimization is the staining for subsequent 165 

imaging time points. Aquilegia meristems were stained for 2.5 minutes for time point 1, 166 

then 2 minutes for time point 2 and 3, and 2-3 minutes for timepoint 4.  167 

2. Carefully pipette off the stain and wash the meristems with ddH20 three times, by 168 

pipetting. 169 

 170 

E. Imaging 171 

 172 

Notes: Imaging will differ depending on the type of confocal and objective lenses available, as 173 

well as the type of tissue or stain used. 174 

 175 

1. Meristems were imaged immediately after staining using a LSM 980 NLO Multi-photon 176 

confocal laser scanning microscope (Ziess, Germany) equipped with a water immersion 177 

objective (W Plan-Apochromat 20x/1.0 DIC UV-IR M27 75mm, Ziess).  178 

2. The petri dishes were filled with ddH2O while imaging, and the water was immediately 179 

removed after imaging. 180 

3. A DPSS 514nm laser was used for excitation and emission was collected between 580-181 

670nm.  182 
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4. Scans were frame averaged 2x and z-sections taken at 2µm intervals. This interval will 183 

vary depending on the size of the tissue, and we found that 2µm was sufficient for 184 

downstream analysis while also minimizing the time the tissue was subjected to the laser.  185 

5. After imaging, the remaining water in the petri dishes was carefully removed by pipetting 186 

using a P20 pipette and the petri dishes were returned to the tissue culture growth 187 

chamber.  188 

6. Samples were imaged every 48 hours, typically 3-5 timepoints. 189 

 190 

IMAGE PROCESSING 191 

 192 

Note: The following protocol for conducting segmentation and lineage tracing of the confocal 193 

images are adapted from (de Reuille et al., 2014; Strauss et al., 2019), and the user manual at 194 

https://www.mpipz.mpg.de/MorphoGraphX/help, all of which detailed the structure of 195 

MorphoGraphX (MGX), including how the image data are stored, extracted, and processed. 196 

Here, we focus on the steps and parameters that are specific to processing confocal images of 197 

Aquilegia floral meristems and steps to reproduce figures in Min et al. (2021). We will use two 198 

original .czi files from our study as an example, which can be downloaded from this google drive 199 

link: https://drive.google.com/drive/folders/1WjaCieLGrnTW7d51143b8HOn-200 

dYmsMU-?usp=sharing  201 

A. Software installation and equipment setup 202 

Download the newest version of MGX from https://morphographx.org/software/. Since 203 

the software improvements have mostly been implemented in the Linux versions, installation of 204 

the Linux operation system is preferred. To run MGX requires a computer nVIDIA graphics card 205 

that supports CUDA, with at least 2 Gb of video memory and 8 Gb of the main memory of the 206 

computer itself. A larger video memory, a larger main computer memory, and/or a multi-core 207 

CPU can significantly shorten the processing time of some of the steps. 208 

Processing a large amount of imaging data with MGX can be time-consuming, and we 209 

strongly recommend readers have a comfortable workstation with proper office ergonomics if 210 
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possible. An ultrawide monitor, or a dual-monitor setup, can be extremely helpful especially 211 

during the parental lineage tracing error correction process.  212 

B. Load image into MorphoGraphX 213 

1. Convert the format of the stack image: Open the stack image (e.g. the 214 

20210207_r8_A1.czi files) with FIJI (https://imagej.net/Fiji) or ImageJ: 215 

(https://imagej.net/Welcome), adjust the brightness and contrast, and save the image as 216 

20210207_r8_A1.tif format. 217 

Note: The images we acquired from the confocal microscope can be dim because we wanted to 218 

minimize tissue damage from both laser power and laser exposure time (which in turn slows 219 

down the growth), and thus the adjustment in brightness and contrast was almost always needed. 220 

Slightly over-saturated images usually look very good when loaded in MGX (Fig. 3). 221 

 

Figure 3. Comparison of how a confocal stack looks in ImageJ and MGX before and 

after adjusting the brightness and contrast. Images that appear to be slightly over-saturated 

in ImageJ generally look good in MGX. 

 222 

2. Load the stack into MorphoGraphX: either drag the 20210207_r8_A1.tif file directly onto 223 

the MGX interface (Fig. 4), or Stack1 → open → choose the image. 224 
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Figure 4. Overall layout of MorphgraphX interface. 

 225 

3. If the stack still appears to be dark, there are two ways to directly adjust the brightness in 226 

MGX instead of adjusting the brightness/contrast in Fiji and loading the stacks again: 1) 227 

under the Main tab, under Work, change Opacity; 2) go to the View tab, and change the 228 

brightness and contrast under View Quality. 229 

4. You can rotate the stack by using the left click of your mouse, move the stack to different 230 

parts of the screen with the right-click, and zoom in and out with the scroll wheel. By 231 

default, Stack 1 will appear green (and Stack 2 will be red), the setting of the colors can 232 

be changed using the Main Stack Colormap  under the Main tab.  233 

C. Extract the surface 234 

1. Go to tab, Process → Stack → Filters → Gaussian Blur Stack; change all the X/Y/Z 235 

Sigma parameters (appears at the right bottom corner; double click the cell to change) to 236 

1; run the process twice (either by double-clicking the processor or hitting the “Run” 237 

arrow  on the upper right corner).  238 

Note: It is important to blur each stack the same number of times, especially when dealing with 239 

images for lineage tracing.  240 
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2. Run Process → Morphology → Edge Detect, which creates a solid global shape of the 241 

object.  242 

3. Optional: remove unwanted parts. For example, if we only want the top part of the 243 

meristem, we could remove the extra stamen/staminode primordia by clicking on “Voxel 244 

Edit ” on the top bar; Press Alt-key and left click of the mouse to erase parts that you 245 

don’t want.  246 

Note: 1) If the Alt-key is not working, it is likely due to a conflict in the hotkey setting in your 247 

operating system, which already assigned a function to the Alt-key and thus prevents it from 248 

being used for selection in MorphoGraphX. You can change this setting in your operating system 249 

by assigning other keys to avoid the conflict. 2) Removing unwanted parts using the voxel edit 250 

can increase the speed of downstream processes, but the removal of parts is not reversible, so 251 

this step is generally not recommended unless there is a significant constraint on the computer 252 

capacity. 253 

4. Optional: If there are holes on the shape, run Stack → Morphology → Fill Holes. Skip if 254 

no hole is observed.   255 

Note: The adjustable parameters in this step are the X/Y-Radius. The bigger they are, the better 256 

they can fill the holes. However, the bigger they are, the more possible it is going to change your 257 

surface shape. 258 

5. Go to Mesh → Creation → Marching Cubes Surface, change the threshold parameter to 259 

20000, run the process.  260 

6. Trim off the bottom. In the Main tab, ensure that the Mesh checkbox and “View” option 261 

are set to “All”. This will enable the visualization of the mesh. Click the “Select points in 262 

mesh (Alt+V) ”  tool on the left toolbar and hold the Alt-key to select the bottom 263 

vertices of the apex. The selected vertices should turn red. Hit the delete key on the 264 

keyboard to remove them. To make this easier, it is nice to have the apex in a horizontal 265 

position. You can do this by left-double clicking on it. Try to delete the bottom cleanly. 266 

Save the mesh as “20210207_r8_A1_s.c6.mgxm” 267 

7. Run Mesh → Structure → Subdivide. Then go to Mesh → Structure → Smooth Mesh, 268 

change the Passes number to 10 (the default is 1), and run the process. Repeat this 269 

subdivide step and then smooth the process two more times (i.e. three times in total). By 270 
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now the total vertical number (shown in the bottom left window) in the mesh for an early 271 

stage FM should be above 500,000, while for an older stage FM should be about 272 

1,000,000.  273 

Note: Each subdivision increases the total vertical numbers by roughly four times. The last 274 

round of subdividing and smoothing can be demanding on computational power.  275 

8. Save the mesh as “20210207_r8_A1_s.c8.mgxm” 276 

9. Go to the Main tab, Unselect “Mesh”. Make sure “Main” and “Surf” are selected, but 277 

“Work” is not. Then run Process → Mesh → Signal → Project Signal to project the 278 

signals to the surface. 279 

Note: The default Max Dist (µm): 6.0 is good for Aquilegia floral meristems since they have 280 

relatively large cells especially compared to Arabidopsis meristem cells. If visualizing a tissue 281 

with smaller cells, the Max Dist can be decreased accordingly. 282 

10. Save the mesh as “20210207_r8_A1_s.c10.mgxm” 283 

D. Cell segmentation. 284 

1. Go to Process → Mesh → Segmentation → Auto-segmentation and change the following 285 

parameters from default: normalize to “No”, auto-seeding to 3.0, blur cell radius to 3.0, 286 

combine to 1.1. Run the process.  287 

Note: The auto-segmentation process can be demanding to the computational power. For 288 

Aquilegia floral meristems, depending on the developmental stages, we got good results by 289 

changing the auto-seeding and blur cell radius to 2.0, 2.5, or 3.0. The radius for auto-seeding 290 

and blur cells should be the same.  291 

2. Save the mesh as “20210207_r8_A1_s.d2.mgxm” 292 

E. Correct segmentation errors 293 

No matter how good the image stack is, there are likely to be segmentation errors, 294 

especially with samples such as Aquilegia floral meristems that contain hundreds to thousands of 295 

cells in a stack. It is very important to correct as many errors as possible at this step since it will 296 

greatly reduce the time that will likely be needed in future processes to correct parental labeling 297 

errors (which is relatively more time-consuming compared to correcting segmentation errors). It 298 

is also important to constantly save the newer version of the mesh (e.g. 299 
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20210207_r8_A1_s.e0.mgxm). The two processes with opposite functions, “Watershed 300 

Segmentation” and “Segmentation Clear”, are located right next to each other on the list, and it is 301 

not impossible to click the wrong button during processing. If the “Segmentation Clear” is run by 302 

accident on the whole mesh while the newest version of the corrected mesh has not been saved, it 303 

means starting over again.  304 

Checking segmentation errors can be done by zooming in on one part of the mesh and 305 

selecting “Vtx” under the Surface panel of the Main tab and then accessing the Mesh panel under 306 

the “Cells” option. By toggling back and forth between the checked and unchecked options in the 307 

Mesh checkbox, you can compare the cell wall positions and segment boundaries. Correct all the 308 

possible errors in that region, then move to another part of the mesh, and repeat the process. 309 

There are a few types of common segmentation errors (Figs. 5-7): 310 

1. If a cell is over-segmented: If cell A is over-segmented into A1 and A2, select “Add label 311 

to selection ” on the left toolbar, press Alt-key and click on A1 (or A2). Then select 312 

“Fill label (Alt+M) ” on the left toolbar, press Alt-key and click on A2 (or A1) (Fig. 313 

5). 314 

 315 
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Figure 5. Examples of over-segmented cells. (a) How over-segmented cells (outlined in red) 

look under the Surface/Cells view. (b) How over-segmented cells (outlined in red) look under 

the Surface/Vtx view. (c) How the mesh looks. Over-segmented cells can be easily spotted by 

comparing between (c) and (b). (d) How cells look after over-segmentation has been 

corrected. 

 316 

2. If a cell is under-segmented: This is a relatively common situation for cells at the 317 

boundary of the stack (due to faint signals) and at the organ boundaries (because the cells 318 

at the boundary are much smaller than the auto-segmentation radius). Click “Select points 319 

in mesh (Alt+V) ” on the left toolbar, press Alt-Key and select parts of the cell that 320 

needs to be corrected (as long as some vertices in that cell were selected it is fine), then 321 

under the Process tab, run Mesh → Selection → Extend to Whole Cells, which selects all 322 

the vertices in that target cell (Fig. 6). On the left toolbar, click on “Erase selected ” 323 

to remove the labels from the cell. Labels can also be removed by running Mesh → 324 

Segmentation → Segmentation Clear under the same Process tab (Fig. 6). Then choose 325 

“Add new seed (Alt+B) ” from the left toolbar, press the Alt-key, and the left click of 326 

the mouse to draw the outlines of the cells (Fig. 6). Theoretically, the cells can be 327 

segmented as long as there is at least one seed inside, but drawing out the rough outlines 328 

of the cells can help with correct segmentation because sometimes the cell boundaries are 329 

faint. Lastly, under the Process tab, run Mesh → Segmentation → Watershed 330 

Segmentation (Fig. 6). 331 
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 332 

 
Figure 6. Examples of under-segmented cells. (a) A under-segmented cell outlined in red. 

(b) Under-segmented cells can be easily spotted by comparing the segmented outlines to the 

original mesh. (c) The label of the under-segmented cell being cleared. (d) The two cells being 

re-seeded. (e) How the labels look after the under-segmentation is corrected. 

 333 

3. If the boundary of a cell is incorrect: This is most likely due to a faint signal in the cell 334 

wall staining (Fig. 7). On the left toolbar, click “Add label to selection ”, then press 335 

the Alt-key and click the cell that needs to be corrected. Then choose “Add current seed 336 

(Alt+N) ” from the left toolbar, use the left click of the mouse to fill in the gaps, and 337 

draw the correct boundary (Fig. 7). Then under the Process tab, run Mesh → 338 

Segmentation → Watershed Segmentation (Fig. 7). 339 

 340 

 

Figure 7. Example of a cell with incorrect boundary. (a) Red arrow pointing to the 

incorrect boundary of a cell. (b) How the original segmentation looked. (c) How the corrected 

segmentation looked. 
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4. Remove the cells on the boundary of the mesh: After all visible errors are corrected on 341 

the mesh, run Mesh → Cell Mesh → Fix Corners Classic under the Process tab. Then 342 

click “Select points in mesh (Alt+V) ” on the left toolbar, press Alt-key and select 343 

cells on the boundary of the mesh, then under the Process tab, run Mesh →selection → 344 

Extend to whole cells. After the cells are selected, click “Delete selected” on the left 345 

toolbar, then save the mesh as “20210207_r8_A1_s.e4.mgxm”.  346 

 347 

This last step is important because the sizes of the cells on the boundary are likely to be 348 

inaccurate due to several reasons: 1) the confocal Z-stack may have stopped scanning at this 349 

point without including the entire cell on the boundary; and 2) we arbitrarily trimmed off the 350 

bottom of the stack in step C6, which may have trimmed off parts of cells located on the 351 

boundary (Fig. 8).  352 

After the first layer of cells on the boundary is removed, run Mesh → Cell Mesh → Fix 353 

Corners Classic under the Process tab again, and save the mesh again. This will be the mesh (i.e. 354 

20210207_r8_A1_s.e4.mgxm) that is used to conduct lineage tracing.  355 

 
Figure 8. Removing cells on the boundary of the mesh.  (a, b) How the labels look before 

removing the cells on the boundary, which had unnatural shapes. (c) How the labels looked 

after removing the cells on the boundary. 

 356 

PARENT LABELING & LINEAGE TRACING 357 

After processing the stacks and meshes from both time-point 1 358 

(20210207_r8_A1_s.e4.mgxm) and time-point 2 (20210209_r8_A1_s.e4.mgxm), they are ready 359 

to conduct parental labeling and lineage tracing. 360 
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A. Parental labeling 361 

1. Go to the Main toolbar, load the segmented mesh for time point 1 on Mesh 1, and the 362 

segmented mesh for time point 2 on Mesh 2. Both meshes are now loaded as meshes of 363 

Stack 1 and 2 under the Main tab respectively. The main stacks (i.e., the original .tif files) 364 

can also be loaded using the Main toolbar for Stack 1 and 2. It is a personal preference 365 

whether or not to load the main stacks because they are not required for the lineage 366 

tracing process, but it might look nicer to have the main stack shown when taking 367 

pictures.  368 

2. Go to the View tab, and check “Stack1” in the Control-Key-Interaction panel. This 369 

allows you to move the meshes separately. Using the right click of the mouse alone will 370 

move both meshes together, but using the right click of the mouse while pressing the 371 

Control-key on the keyboard will only move the Stack 1. Use the control key and the 372 

mouse to move Stack 1 and 2 side by side on the screen.  373 

3. Go to the Main tab Stack 1, next to the Mesh checkbox, click Colors Editor  to 374 

change the colors of Mesh 1 and/or Mesh 2 so that they are different from each other. 375 

4. Go to the Main tab Stack 1, make sure the checkboxes of Main, Work, and Surface 376 

panels are all unchecked, but the one for Mesh is checked. Make sure that “Cells” is 377 

selected as the view option for both the Mesh and the Surface panels, and the view option 378 

for Cells is selected as “Label”. 379 

5. Go to the Main tab Stack 2, uncheck Main and Work, but check Surface and Mesh. The 380 

view options for Surface and Mesh should be “Label” and “Cells” as well, respectively. 381 

Then check the checkbox of Parents to the right of the Surface checkbox. The colored 382 

segmented cells of Stack 2 should disappear after this.  383 

6. When the meshes of the meristems are first loaded, we see the front view of the 384 

meristems. Use the left click on the mouse and the Control key to adjust the orientations 385 

of both meshes so that the side views are shown. 386 

7. Use the left click of the mouse and the Control key to move the Mesh 1 above the Mesh 387 

2. Then use the left click of the mouse alone to rotate both meshes so that the front views 388 

are shown again.  389 

8. Look for a few cells on Mesh 1 and 2 that appear to be the same. Usually, the large cells 390 

at the center of the meristems are the most easily recognizable. Transfer the Mesh 1 on 391 
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top of Mesh 2 by pressing the Control-key and using the right click of the mouse to 392 

match those recognized cells on both meshes.  393 

9. Adjust the orientation and angles of Mesh 1 using the left click of the mouse and the 394 

Control-key to make more cells on both meshes overlap. If the growth between the two 395 

time points is rather large, adjust the size of the Mesh 1 by going to the Main tab Stack 1, 396 

check the Scale checkbox, and increase the X values (adjusting Y or Z is also fine since 397 

all axes are linked). 398 

10. To transfer labels from Mesh 1 to Mesh 2, go to the Main tab Stack 2 so that Stack 2 is 399 

active. Select “Grab Label ” from the left toolbar, hold the Alt-key, and click on the 400 

cells that are aligned on both meshes. If a cell at time-point 1 appears to have divided at 401 

time-point 2, click both cells and they will appear to be the same color.  402 

11. Transfer labels of all possible cells from Mesh 1 to Mesh 2. Because of the meristem’s 403 

3D structure, it is impossible to grab labels of all matching cells without adjusting the 404 

angles and orientation of the meshes. We recommend that users deal with one subregion 405 

of the mesh at a time (just like when correcting the segmentation errors): start from the 406 

center of the meristem, move down from the center to one edge of the mesh, label all 407 

possible cells in that region, then move on to the adjacent region. It is also possible that 408 

different regions of the samples require independent adjustments to the mesh sizes, which 409 

will require the user to use the Scale function (Step A9) repeatedly. For example, when 410 

tracing cells on the newly initiated primordia, the size of Mesh 1 will likely need to be 411 

scaled up greatly to match the cells on the Mesh 2; but when tracing cells on the 412 

boundary regions, Mesh 1 will most likely not need to be scaled. A video demonstration 413 

of lineage tracing can be found on: 414 

https://www.youtube.com/watch?v=KDiCyGrALYk&t=26s 415 

12. Save the parents' labels by running Mesh → Lineage Tracking → Save Parents under the 416 

Process tab. Make sure Stack 2 is active when saving the parents (otherwise an empty file 417 

will be saved). Use caution when saving because the Save Parents option is listed 418 

adjacent to Reset Parents, and the consequences of accidentally running the wrong 419 

process can be detrimental. Make sure to label the lineage tracing file informatively and 420 

identify the version, since multiple versions may need to be saved when correcting 421 
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lineage tracing errors (because there is no undo button!). For instance: r8-A1-422 

0207to0209-v1.csv. 423 

 424 

B. Correcting lineage tracing errors 425 

Although it is not necessary to correct lineage tracing errors to generate a growth heat 426 

map, it is important to correct all errors before running any analysis to ensure the accuracy of the 427 

results. To check the correspondence of the traced cells, make sure Stack 1 is active, and under 428 

the Process tab, run Mesh → Cell Axis → PDG → Check Correspondence. The cells with errors 429 

will be highlighted in red on both meshes. To correct the errors, the original meshes of time-430 

point 1 and time-point 2 need to be opened in two additional, separate MorphoGraphX windows, 431 

which is why we have recommended that users have an ultrawide monitor or a dual-monitor 432 

setup. Opening the meshes in additional windows is necessary because the meshes in the lineage 433 

tracing window have been simplified, so that only the vertices at the junctions between cells are 434 

present. Therefore, any modification of the meshes should be done on the original mesh rather 435 

than the mesh being checked for correspondence. 436 

The error correction process consists of repetitive steps of 1) zoom in on one region of 437 

the meshes of the lineage tracing window, 2) identify the sources of errors, 3) correct the error on 438 

the original mesh 1 or 2, 4) save the updated versions of the original mesh and load it in the 439 

lineage tracing MorphoGraphX window again, 5) re-run “Check Correspondence” to make sure 440 

all the cells in the region are blue, and 6) move on to the next region with errors in the lineage 441 

tracing window until all the errors are corrected.  442 

There are a few common types of errors in check correspondence: 443 

1. Parental labeling error or segmentation error on the original meshes. If either kind of 444 

error occurs, the area on Mesh 1 will look like (Fig. 9a). Turn on the checkbox for 445 

Surface for both Stack 1 and 2, make sure Cells are selected, and the view option is set 446 

to Label. Compare the colors of the cells in that location to determine whether a cell was 447 

wrongly labeled, or the original mesh was wrongly segmented. 448 

o If the cells on Mesh 2 had the wrong parental label, repeat steps 8 to 10 in Part A 449 

(Parental labeling) but only for the cells with error. Make sure Stack 2 is active and 450 

save the parents’ labels by running Mesh → Lineage Tracking → Save parents under 451 
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the Process tab. We recommend saving the new version of the parental labels as a 452 

new file, no matter how trivial the modification may have seemed to be.  453 

o If the error is due to segmentation error on the original mesh, it would be because 454 

either a cell on Mesh 1 is under-segmented or the cell on Mesh 2 is over-segmented. 455 

Check the original meshes as described in Step 5, and save the modified mesh as a 456 

new, separate file. 457 

2. Errors at the cell junctions. This is likely to be the most common error in Check 458 

Correspondence and the junctions in question will be indicated in Mesh 1. They are 459 

usually due to tiny differences in how neighboring cells connect to each other in Mesh 1 460 

and 2 (Fig. 9b). Zoom in on the junction in question in both Mesh 1 and 2, compare 461 

check and uncheck the Mesh checkbox to identify which mesh should be corrected. 462 

Then use “Add label to selection ” on the left tool bar, then press Alt-key and click 463 

the cell that needs to be corrected. Then choose “Add current seed (Alt+N) ” from the 464 

left toolbar, use the left click of the mouse to fill in the junction. Then under the Process 465 

tab, run Mesh → Cell Mesh → Fix Corners Classic, and save the modified mesh as a 466 

new, separate file. 467 

 
Figure 9. Examples of lineage tracing errors. (a) Two major types of errors. Left: Most 

likely due to incorrect parental labeling or in correct segmentation, e.g. Stack 1 is over-

segmented, but only one of the cells can be mapped to Stack 2. Right: Most likely due to 
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incorrect cell junctions. (b) An example of why junction error can occur. In Stack 1, Cell A 

and D were physically connected to each other but C and B were not, while in Stack 2, C and 

B were physically connected to each other. 

 468 

DATA ANALYSIS 469 

 After all the errors are corrected, reload Mesh 1 and 2 to Stack 1 and 2, respectively. 470 

Make sure Stack 2 is active and the Parents box is checked. Under the Process tab, run Mesh → 471 

Lineage Tracking → Load parents and load the latest version of the parental tracing file.  472 

For all the heat maps, the scale of the values can be changed in Process → Mesh → Heat 473 

Map → Heat Map Range; the styles can be changed by clicking the Colors Editor  next to 474 

the view option of Cells in the Surface panel; and screenshots can be taken by clicking the Save 475 

screenshot  on the main toolbar. All the original images from Min et al. (2021) were saved 476 

as .PNG in 2700 px (width) x 2500 px (height).  477 

A. Heat maps of cell area expansion and cell proliferation 478 

1. To create a heat map for cell area expansion, under the Process tab, run Process → Mesh 479 

→ Heat Map → Heat Map Classic. Select “Area” for the heat map type and “Geometry” 480 

for the visualization. Differences in various change map options can be found on the 481 

MorphoGraphX manual. Also select the “Change map” checkbox. This tells 482 

MorphoGraphX to make a heat map comparing Stack1 and Stack2. The heat map can be 483 

visualized on either the first (typically, Stack1) or second (Stack2) time point. For the 484 

growth sample here, select “Increasing” if Stack 1 (i.e. time-point1) is active or 485 

“Decreasing” if Stack 2 (i.e. time-point 2) is active.  486 

2. To create a map of cell proliferation, make sure Stack 2 is active, and run Process → 487 

Mesh → Lineage Tracking→ Heat Map Proliferation.  488 

3. To create images such as Fig. 3 in Min et al. (2021), in which divided cells are 489 

highlighted on a cell area extension heat map, first run cell area expansion heat map on 490 

Stack 2. Check “Report to spreadsheet” so that the values of cell area expansion for each 491 

cell can be saved. Give the spreadsheet an informative name, such as “r8-A1-tp1_tp2-492 

growth-allcells.csv”. Then create a map of cell proliferation by running Process → Mesh 493 
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→ Lineage Tracking→ Heat Map Proliferation. Subsequently, run Process → Mesh → 494 

Heat Map → Heat Map Select, change the range values: Lower Threshold to 2, Upper 495 

Threshold to 3 or higher. This step will select all the cells that have experienced cell 496 

division. Then go to Process → Mesh → Heat Map → Heat Map Load, load “r8-A1-497 

tp1_tp2-growth-allcells.csv” as the Heat Map file, and make sure the Column to load is 498 

set as “Value”.  499 

4. The aesthetics of the growth heat map and cell outlines can be changed in the Main tab. 500 

To change the cell outlines, go to Main → Stack 1 → the Colors Editor  by the 501 

Mesh panel. To change the heat map styles, go to Main → Stack 2 (if heat map is 502 

displayed on Stack 2) → the Colors Editor  by the Cells in the Surface panel. 503 

Sometimes the heatmap color scale appears to be incorrect on the screen. This is most 504 

likely to happen when both Stack 1 and Stack 2 are displaying heat maps, and the color 505 

scale of Stack 1 will cover the color scale of Stack 2. This can be simply solved by 506 

unclicking the Surface panel under Stack 1. 507 

B. Heat maps of principle direction of growth and anisotropy 508 

1. Make sure the parental file has been loaded to Stack 2 and then switch to Stack 1 to 509 

designate it as the active stack. Under the Process tab, run Mesh → Cell Axis → PDG → 510 

Check Correspondence, No error should show up since the meshes have been corrected. 511 

Make sure the active Stack is the stack that you want to display the heat map on, so if you 512 

want to display heat map on time-point 2, make Stack 2 as the active stack. Then run 513 

Mesh → Cell Axis → PDG → Compute Growth Directions. The PDG values can also be 514 

saved by running Mesh → Cell Axis → Cell Axis Save. Detailed explanations of the 515 

PDG parameters can be found in the MorphGraphX manual.  516 

2. To change the display of the PDG map, go to Mesh → Cell Axis → PDG → Display 517 

Growth Directions. The PDG heat maps in Min et al. (2021) were displayed as 518 

Anisotropy, which is the ratio between StretchMax and StretchMin. A ratio of 1 means 519 

no deformation, 2 means an elongation by 100%, 0.8 a shrinkage of 20%. The color and 520 

size of the PDG vectors can also be modified. By default, vectors corresponding to 521 

expansion (stretch ratio > 1) are displayed in white, while red is used to draw the 522 

direction of shrinkage (stretch ratio < 1). The “Threshold” parameter is used to display 523 
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PDGs axis only in cells for which the anisotropy is above a given value. Since we save 524 

each image at a relatively high resolution (2700 x 2500), we found that a Line Width of at 525 

least 10 px is needed for good visualization on the final screenshot.  526 

 527 

PERSPECTIVES 528 

In this study, we presented the first quantitative live-imaging protocol of floral buds of A. 529 

coerulea, which offers considerable potential for application to other non-traditional plant 530 

systems. However, there is still room for improvement to obtain higher quality quantitative data. 531 

First, our samples were stained with propidium iodide (PI), which generally gave good signal in 532 

most of the tissue, but cells in the organ boundary regions were often under-stained. Repetitive 533 

long-term staining with PI is known to become toxic to tissues and thus slow growth (Grandjean 534 

et al., 2004; Bureau et al., 2018), which was also the primary factor that restricted the length of 535 

the analyzed developmental window. Further development of transgenic markers for the plasma 536 

membrane would help to solve these issues. Second, our analysis was limited to surface 537 

reconstruction of the cells, although the behavior of cells under the epidermal layer is an 538 

indispensable part of fully understanding meristem morphogenesis. Third, due to the imaging 539 

mechanisms of the available confocal microscope, cell walls perpendicular to the focal axis of 540 

the microscope were often not detected. Combined with the fact that cells at the organ boundary 541 

were often poorly stained, we were often unable to segment and analyze cells in many boundary 542 

regions on the abaxial side of some primordia. Except for the issue with PI staining, all of the 543 

other limitations described here are, in fact, challenges faced by similar studies in the established 544 

model systems (Rambaud-Lavigne & Hay, 2020; Prunet & Duncan, 2020). Fortunately, rapid 545 

development in microscopes that allow long-term, deep-tissue, minimally invasive scanning, as 546 

well as software developments that can segment and reconstruct multiple cell layers in 3D from 547 

the imaging data, are in progress. A comprehensive understanding of "the genetics of geometry" 548 

(Coen et al., 2004) of morphogenesis in a diverse set of plant systems is hopefully underway. 549 

 550 

  551 
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